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Chapter 4   

Page Designer  
 

 In this Section:  
  
• Introduce the Page as a basic component 
• Discuss how the Project Tree and Property Panel relates to the Page 
• Show how to select component(s) 
• Learn how to re-size and move components 
• Overview of cutting and pasting in Rave 
 

Overview  
Just knowing the components and tools is not enough to work effectively in Rave. One must also 
learn about the most fundamental component of Rave, which is the Page. In this chapter the 
Page and its relation to the Project Tree and Property Panel are explained in detail. Although the 
Project Tree and the Property Panel have their own chapter, as each are important individually, 
this chapter explains how each is related to the Page. Also in this chapter, some basics on 
moving objects on the Page are given. 

The Basic Component: The Page & it's Panels  
The base component of the Rave Visual Designer is the Page. The Page is not a normal 
component in that it is not on a Component Toolbar, but it does have properties and it will help to 
think of it as the base component that provides the container for the report design. All Rave 
components must be placed on the Page. The Page is represented by the grid pattern on the 
page panel. The look and feel of the Page is controlled by preference settings that are covered in 
the Preferences Chapter. Changing the visual look of the Page is discussed in the Utility Toolbars 
Chapter in the Designer Toolbar section. 

 

 

Like all components, the Page also has properties such as height, width, description and name. 
To see or change the Page properties, go to the "Project Tree" panel and expand the Report 
node by clicking on the "+" sign, then click on the report name ("Report1" is the default report). 
Clicking on the report name will show "Page1", which is the default name for a Page. Click once 
on this and notice that "Page1" will be highlighted. This means that the Page has been selected 
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and now the Page properties for that Page will be seen in the Property Panel. 

 

 

Page properties allow a report to be more informative. For example, rather than have a report 
with Page1, Page2, Page3, it might be desirable to have the pages named Invoice, PO, 
PackingSlip. To do this, use the "Name" property in the Property Panel. The name can be 
anything the user desires, but note that the name cannot have any spaces or special characters. 
Remember the Name is for the Rave designer only and is visible only in the Project Tree and on 
the tab(s) of the Page panel. 

In the image of the Project Tree and Property Panel, the page names have been changed to 
show how useful it is to rename the Page. Now the project tree looks more informative. It is useful 
and helpful to adjust any properties associated with the Page to make the report more informative 
and useful for future use and revisions. 

Selecting Components  
Selecting components is as easy as clicking on them. Moving the mouse pointer to the region 
where the component is and clicking the left mouse button once will select any component that is 
placed on the Page. A selected component will appear surrounded with a line that has colored 
dots, called pips. 

The "pips" can be of four different colors: green, gray, red, and yellow. Green pips indicate that 
the current component is the only one selected. Gray pips show that there is more than one 
component selected, and red pips indicate that the current component is locked. The yellow pips 
indicate objects that are that have been mirrored and cannot be modified. 

Selecting more than one component at a time is done in a similar way to selecting one 
component. The difference is that when selecting multiple components; hold down the Shift key 
while clicking on the objects. 

Another way to select either one or more components is to draw a "virtual" box around them. To 
do this, select an area that is adjacent to the component and drag the mouse to surround the 
component(s) keeping the left mouse button clicked. 

To unselect a component, simply click on the Page Designer tab or move the cursor selection to 
a different component by clicking on it. 

When multiple components are selected, only the common properties will be displayed in the 
Property Panel. When a property changes, the change will affect all the selected components at 
that time. 

There is a special property for all components called Locked. If the Locked property is True, the 
component can be selected, but it's properties cannot be changed (except for the Locked 
property, of course). If selected components are locked, then the pips and the property name for 
those items will be red (as mentioned previously). If the component is a child component to a 
parent component, the parent will control the locked access. The Locked property state drop-
down menu will show either a True/False indicating the lock status or it will show the parent 
component name that is controlling its lock state. The remaining discussion is about components 
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that are NOT locked. 

Sizing and Moving Components  
To move a component, simply click on it with the left mouse button and drag it to the desired 
area. When more than one component has been selected, they can all be moved by just moving 
one of the components. Note that this will NOT affect components that have the Locked property 
set to True. 

The main purpose of the "pips" that appear when selecting a component are for resizing. 
Resizing only works on ONE component at a time, i.e., a group of selected components cannot 
be resized at one time. A component can either be resized vertically, horizontally or diagonally. If 
the resizing is done diagonally, the component will resize both vertically and horizontally. Simply 
click on one of the pips with the left mouse button and drag the pip until the desired position. 
Locked components cannot be resized. 

Cutting and Pasting  
Cutting and pasting is achieved in the same way as in any other standard Windows applications. 
After selecting a component (or group of components), choose Cut or Copy from the Edit menu; 
or use the Ctrl-X or Ctrl-C key combinations; or right click on the component and selecting Cut or 
Copy from the popup menu. 

To paste the components, choose from any of the three previous methods (Edit menu, Ctrl-V or 
popup menu). 

Again it is important to point out that Locked components cannot be cut since this would involve 
removing the object from its position. 

Exercise: Selecting, Sizing, and Moving Components  
To select a component: 
1. Click on the component. The pips and border will appear around it 
2. Or, click on the component in the Project Tree, and notice that the selected component 

will be highlighted. 

 

 

 

To resize a component: 
1. Select the component 
2. On a pip, place cursor over it until it changes to a double arrow 
3. Click and hold the pip, then drag to the desired size 
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To move a component: 
1. Select component 
2. Move cursor over component (not near a pip, as that would be resizing the component). 

Click on component and hold 
3. Move component by dragging cursor, and thus the component 
4. Place in desired location. 
5. Release cursor 

 

Exercise: Cutting and Pasting  
Using Edit menu: 
1. Select the component. 
2. Select Cut from the Edit menu. This will place the component into the clipboard, and the 

component will disappear visually from the page. 
3. Paste by selecting Paste from the Edit menu. 

 

Using the short-cut keys: 
1. Select the component. 
2. Press Ctrl-key and X-key. This will place the component into the clipboard, and the 

component will disappear visually from the page. 
3. Paste by pressing Ctrl-key and V-key. 

 

Using the pop-up menu: 
1. Select the component. 
2. Right-click on the component, in the pop-menu select Cut. This will place the component 

into the clipboard, and the component will disappear visually from the page. 
3. Paste using one of the two previously mentioned ways. 
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Chapter 5   

Project Tree Panel  
 

 In this Section:  
  
• Project Tree structure introduced 
• General discussion of Parent-Child relationships 
• Introduce the main project categories 
• Show How to Load/Unload Global Pages 
• Discuss and explain the Drag and Drop features 
 

Overview  
The Project Tree Panel provides an easy way to navigate through the report design structure. 
This tree style view gives an outline overview of the report pages and the report structure. Thus, 
this makes the Project Tree a very informative part of the Rave designer. Once you have 
designed some simple or complex reports, remember to visit this panel and see just how 
informative it can be. 

 

 

A project can contain multiple definitions within each main category: Report Library, Global Page 
Catalog and Data View Dictionary. Each node (and any sub nodes) can be expanded or 
collapsed by clicking on the plus/minus symbol. Any of these main nodes can be added from the 
"Project" menu option. There you will see an option for each of the nodes "New Report", "New 
Global Page" and "New Data View". In order to add a "New Page" to a Report in the Report 
Library, activate the Report that and use "New Page" from the Project menu. 

Expanding and Right-Clicking  
An easy way to complete tasks on items in the project tree is to right-click on the item. There are 
many different pop-up menus available. Clicking on a Main Node like the Report Library brings up 
a popup menu with two choices: Expand All and Collapse All. These two choices refer to 
expanding and collapsing all the nodes, which would provide easy fast access to all items in that 
tree. 

A right-click on a sub-node, like on a Page, would reveal the option of deleting a page. Some of 
the available functions may be few or many, as in the next image. 

Right-clicking on a component can display a pop up menu with many options. These options are 
the same options available as if a right-click was completed on the component on the designer 
page. Also, these items reflect the options available to the component through the Utility toolbars. 



RAVE Reference Manual 

Page 28 

There are many options that may be available with a right-click of the mouse. To speed up the 
report making process or to make navigating a report fast and easy try to become familiar with 
the options that are available through these popup menus. 

Parent-Child Relationship  
Now, that you have seen how to click through the Project Tree, we'll review some lingo that is 
associated with a "tree". 

The Project Tree is listed in a way that looks like an upside down tree. The base or the root of the 
tree is at the top of the list. Each subsequent branch is a child of the root. This makes the root 
also the parent of the child or branch. Each branch can also be its own parent and have its own 
child or children. 

The techniques used in the previous section demonstrated how to move through the tree by 
expanding and collapsing the nodes associated with each parent. When a branch has children, a 
node will appear to the left of the branch name. 

The Report Library is the root of the Tree, and has one child called Report1, shown with the text 
highlighted. 

Report1 has several children: Page1, Page2, Page3, Page4, Page5, and Page6. 

Page1 has the following children: Text1, Text2, and Memo1. 

Also there are two sibling groups. Just like in a real family with parents and children, the children 
can have siblings. The first group of siblings: Page1, Page2, Page3, Page4, Page5, and Page6. 
The second group of siblings: Text1, Text2, and Memo1. There are other family associations, but 
the main two that we are concerned with is the Parent-Child relationship. 

Report Library  
The Report Library node is where the design structure, including all the components used, in 
each of the report(s) will be displayed. Normally, a component is selected via the Page in the 
Visual Designer layout panel by simply clicking on the component. However, the Report Library 
tree can also be used to select components by simply clicking on the component name. When a 
component name is clicked, that name will be highlighted. To select multiple components, hold 
the Shift- key down while selecting as many components as you like in the Project Tree. 

A project can be simple with one or two report definitions, or it can be complex with many report 
definitions. Each report that is created would have it's own design structure. To select and switch 
to a different report, simply double-click on that report name in the Report Library tree structure. 

TIP: To make navigation and understanding of a report easier, make use of the Name property. 
See the Name Exercise at the end of this chapter for help in using this property effectively. 

Global Page Catalog  
 The Global Page Catalog node is where Page definitions, which contain templates to 
be mirrored, are kept. This includes things like Letterheads, Forms, Watermark 
designs, and other Page definitions that could be the foundation for several reports. 

This can even be a complete report design. An example would be mirroring a section component 
on a Global Page where the same contents (like an "Invoice") could be printed, but also with a 
different caption at the bottom of the pages like "Original", "File Copy", and "Shipping". 

Loading and Unloading Global Pages  
Global Pages are very useful and helpful to the designer, especially when they can be accessed 
quickly. These pages can hold all sorts of objects and components that can be repeated and 
mirrored throughout many pages in many different reports. Many of the reports in a Report 
Library could make use of any of the Global Pages in the Global Page Catalog. 
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When creating reports, a useful feature of the Rave Designer is the Page Designer Tabs. These 
are located at the top of the Page Designer window. They are the tabs of pages in use. 

Global Pages can be added to this tab for quick referencing, meaning that the designer does not 
need to scroll through the whole Project Tree to find the right Global Pages frequently needed. 
Instead the designer just needs to load the page to the Page Designer Tab area and click on the 
tab when it is needed. Global Pages can be loaded and unloaded to/from the Page Designer Tab 
area by performing a right-click on the Global Page and using the speed menu to make their 
choice. A fast way to unload a Global Page is to select it from the tab area, then click on the Page 
and use the Ctrl-F4 keystroke. 

Data View Dictionary  
The Data View Dictionary node in the Rave Designer is where all the data connections 
for the reports would be listed. To add a Data View to this list, select a "New Data View" 
(from the "Project" menu). This will bring up a "Data Connections" dialog window. This 

window will show all the Rave data connections that are "active". Then select any of these and 
this will create a new Data View attached to that data connection. 

Ctrl- (Control) Drag and Drop  
Ctrl-Drag and Drop is used to create or mirror an item from the Project Tree structure either to 
another age node in that report structure or to the current page on the designer layout. When 
dragging from the Project Tree Panel to the page designer, the drop location will be the location 
where the mouse button is released. However, when dragging from one page node to another (in 
the Project Tree Panel), the location of the drop will default to the same place as the source. 

NOTE: 
When Ctrl-dragging a non-visual component, it must be one that can be mirrored. Copying a 
component that cannot be mirrored will NOT work. Regions and Bands are components that do 
not enable mirroring. To mirror a region, make the region part of a section, and then mirror that 
section. The section could include other components as well. 

CAUTION: 
Drag and drop will work from Report Page to Report Page, Global Page to Global Page, Global to 
Report Page, however, it will NOT work from the Report Page to Global Page, since components 
on Reports are not visible to other Reports and therefore cannot be used as mirrors on a Global 
Page. 

Alt-Drag  
The Alt-Drag is used to change the parent of a component to a new "container" component like a 
Section. All moves of that component need to be within that same Page design. When a new 
Section is created, the user may choose to have items from another Section placed in the new 
Section. In this case the parent must be changed from the old Section to the new Section and 
then the new Section can be mirrored. 

NOTE: 
The target component must be a container type. The Page, Region and Section are all holders or 
containers. So, if there are two or more sections on a Page, items can be dragged from one 
Section to the other Section. Also components can be dragged from the Page to one of the 
Sections. 

Exercise: Navigating the Project Tree  
Because many report projects are complex, the Project Tree's hierarchy helps to navigate 
through the reports. 

To navigate through the hierarchy (expand, collapse, and selection): 
1. Expand an item by clicking the square icon with a "Plus" symbol. This will change the 

item to a "Minus" symbol and expand the items into the sub-items such as Report1, 
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item to a "Minus" symbol and expand the items into the sub-items such as Report1, 
Page1, etc., depending on which level of expansion is being expanded. 

2. Collapse an item by clicking on the "Minus" Symbol. This will change the icon to a "Plus" 
symbol and collapse the items, so that they will no longer be visible. 

3. Select an item in the Project Tree by clicking on the item. Selection will be indicated by 
that item being highlighted. 

  

 
 

 

Exercise: Naming Components  
Since projects can become very complex, it is highly suggested that the "Name" property be used 
to make items in the Project Tree easier to understand. 

By default, the "Name" property will automatically default to something like "Report1", "Report2", 
and so on. However, it would be easier to maintain a project if the reports had useful names. This 
can be done through the "Name" property. 

When developing a naming convention, be creative, but remember no spaces or special 
characters are allowed in the "Name" property. 

In the example Project Tree Panel, the default report names have been changed. Instead of 
dealing with reports listed as "Report1" through "Report7", the reports were labeled accordingly: 
"CustomerList", "CustomerLabels", "CustomerDue", "Invoice", "PO", "ProductsOnHand", and 
"ProductsOnOrder". It is important to understand that the Project Tree Panel is there to make 
overseeing a project easier. But, without an informative naming system, the Project Tree Panel 
will not live up to it's full potential. 

To rename a report (or any other component): 
1. Select the report (component) 
2. Ensure that the report to be renamed has been selected. A selected item is highlighted. 
3. Go to the Property Panel and look at the Name Property. 
4. In the "Name" Property edit box, type in the desired name. 
5. Hit Enter or click somewhere out of the edit box, after a new name has been entered. 
6. Look at the Project Tree and notice that the name of the report (component) has been 

changed from the default name. 

 

Exercise: Loading and Unloading Global Pages  
Loading and Unloading Global Pages to the Page Designer Tab area makes referencing these 
pages fast and helpful. This is especially true when dealing with mirroring sections and objects 
from Global Pages to the pages in different Reports. 

To load a Global Page: 
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1. Start with a new report 
2. Insert about 4 blank reports, by selecting New Report from the Project menu or by 

clicking on New Report from the Project toolbar 
3. Next, select "Page1" in the first report. Do this by using the Project Tree. Click on 

"Page1" in the tree or click on the "Page 1" tab in the Page Designer Tab area. Once that 
Page has been selected, it's name will be highlighted. 

  
4. Add about three Global Pages to the report. Do this by selecting New Global Page  from 

the Project menu or by clicking on New Global Page  from the Project toolbar 
5. Notice that since the first page in the first report was selected when the Global Pages 

were added, the new Global Pages were added to the Page Designer Tab area. The 
pages are also added to the Project Tree under the Global Page Catalog 

6. Click on a different Report page. Notice that once a different page is selected, the Page 
Designer Tab area only has that page in the Page Designer Tab area 

7. To add Global Pages to the Page Designer Tab area right-click on a Global Page in the 
Project Tree and in the menu that pops up select Load Page. Try loading all three 
Global Pages 

8. As the Global Pages are loaded they will be seen in the Page Designer Tab area 
9. Try loading Global Pages to other pages in the last two reports 

 

To unload a Global Page: 
1. Complete the steps from the previous exercise 
2. Select a page from Report 3 that contains all the loaded Global Pages 
3. There are two ways to unload a page. One way is to use the speed menu; the other is to 

use quick keys 
4. The first way, using the speed menu, requires that you first select the page that needs 

Global Pages unloaded 
5. Next, right-click on the Global Page and select Unload Page from the speed menu. Do 

this for all three Global Pages in Report 3 
6. We will use the second way to unload Global Pages next 
7. Select the next page in "Report 4". Make sure it contains all the Global Pages in the 

Page Designer Tab area 
8. Once the page in "Report 4" is selected and you can see the three Global Pages in the 

Page Designer Tab area, select one of the Global Pages from the Page Designer Tab 
area 

9. Now use the Ctrl-F4 keystroke to unload the Global Page 
10. Try this with the rest of the Global Pages in the Global Page Catalog.  

 

Exercise: Dragging a Component (Ctrl-Drag)  
One of the more common items to drag would be to copy a Data Field over to the Page in the 
Visual Designer. The target could be an existing DataBand or just an open area on the Page. The 
Data Field will be converted to a DataText or DataMemo on the target area depending on the 
source's field type. Accomplish this by doing the following steps. 

To drag a component: 
1. Go to the "Data View Dictionary" node, expand it if it is collapsed 
2. Select one of the Data Views and expand it if it is collapsed 
3. Select (highlight) a field component to copy 
4. Press and hold the Ctrl-key, now drag that field over to the Page 
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5. Release the mouse and Ctrl-key when it is at the desired location 
6. Select the newly copied data field and set its properties as required 

 

This exercise may have been a little advanced for this point in the manual, but it is put here to 
give the user the steps necessary to complete a dragging component. So, since a full report has 
not yet been created, don't worry about getting the report working yet. 

Exercise: Changing the Parent of a Component (Alt-Drag)  
Changing the parent of a component can be very helpful, like when trying to group or ungroup 
components. For example, say there was a Page that contained components that would be better 
grouped together into a Section. The current status is that the Page is the parent component of 
the components that need to be grouped. To group the items together, the parent component 
would have to be changed to the section component. After this is done, the items will be in a 
section, which can then be moved around as such. In the reverse sense, maybe a component 
needs to be taken out of a section and needs to just lay on the Page and not the section, just use 
the Alt-Drag to complete this task. 

Changing the parent of a component: 
1. Go to the "Report Library" node; expand it if it is collapsed  

 
 

2. Expand the Report node that contains the Page definition 
needed 

 

 
 

3. Expand the Report node so that both the source and target 
component can be seen. In Customer Statement, there is a 
Section component already on the Page. We will change the 
parent of PageNumInit and Memo1 from the Page to the Section 

 

 
 

4. Select the components that will have their parent's changed. To 
select multiple components, hold the Shift key while clicking on 
each component. When done selecting release the Shift key. 
The desired components should be highlighted 

 

5. Press and hold the Alt key, now drag the source components to 
the new parent component. In this example, the Alt key is held 
while selecting and dragging either of the two components. 
While dragging the components to the new parent, notice that 
cursor changes as it is placed over the target. When the cursor 
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indicates it is over the target, release the mouse button, then 
release the Alt key 

 
 

6. Notice that the components are now under the new parent and 
that the parent has a "minus" sign next to it to indicate that it is 
the parent of some components 

 

 
 

7. When done, the newly moved components can be set as 
required 

. 
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Chapter 6   

Property Panel  
 

 In this Section:  
  
• Defines and describes the Property Panel 
• Explains the different types of properties 
• Describes the property editor 
• Covers the purpose and items in the speed menu 
 

What is the Property Panel  
The Property Panel gives information about the project components. It will be most helpful when 
designing reports because it gives an easy access to all properties associated with each 
component in a report. 

The Property Panel displays and allows modification of values of any component that is placed on 
the Page. To get property information about a certain component, remember to select that 
component before looking at the Property Panel (see Selecting a Component in the Page 
Designer Chapter for more information on how to select an object). 

The Property Panel displays the current properties of a component. For example, by clicking on a 
DataText component, the component will be selected and the Property Panel will display all the 
properties that are available for the component. 

There are three areas to the Property Panel. The first is the very top, which gives the name and 
type of the component. The second area is the middle, where all the component properties are 
listed into two columns. The left column displays the property names and the right column 
displays the current value of those properties. At the bottom of the Property Panel is the third 
area. A Property Hints box, which gives a brief explanation of the currently selected property, is 
located in this third area. 

 



RAVE Reference Manual 

Page 36 

 

 

In the property listing section (middle), the line that separates the two columns can be moved to 
resize the columns to allow for better viewing of the names/values. To do this, move the cursor 
over the line until it changes into the double arrows. Press the left mouse and hold, then drag 
either left or right to resize the columns. 

Remember a component must be selected before the Property Panel will reflect that component's 
properties. It is also possible to select multiple components at the same time. Once a component 
is selected, any of the properties in the Panel can be selected by clicking on the desired property 
name or it's adjacent box selection. With the property selected, it is then possible to change the 
property value. When any of the fields in the Property Panel are selected, the up/down arrow 
keys can be used to move up and down between properties. 

 

 

Some of the property names appear in bold. This indicates that the current value differs from the 
default value. For example, when a DataText component is dropped onto the Page, the default 
color is Black. By changing the color to something other than Black, like Red, the property name 
"Color" changes to bold. When the setting is set back to the default value, the bolding will be 
removed. 

Of what use is the bolding? Let's say for a moment that a report that has been designed by a 
colleague has a problem and it doesn't work. By quickly glancing at the changed properties, this 
will show what properties have been changed, which might in turn reveal the report functionality 
problem. 

While most components can be selected by clicking directly on them, the Page is a special case. 
Clicking on the Page itself in the Visual Designer window will clear the Property Panel of all 
properties, thus not selecting the Page. 

To select the properties of the Page, click on the tab at the top (in the area called the Page 
Designer Tab area) where it shows the page number. Another alternative is to select the Page by 
clicking on it from the Project Tree. 
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Types of Properties  
Every property has an associated type. These types can be numerous, different, and can be 
edited in the Property Panel. The property types can be string, or integer values. 

When editing a string property, it is valid to enter any character that can be displayed on the 
screen. When editing integer values, it is valid to type any numeric value. Decimal numbers are 
another common property that may be edited. 

Often times there are properties that have predefined values that may be selected. These values 
are displayed in the form of lists containing the valid items that can be selected. There are also 
properties that have themselves a number of different properties associated with them. 

Property Editors  
Depending on the type of property selected, there are three types of input boxes available. The 
first one is a simple input box where a value is typed. The value in the input box can be either 
numeric, alpha, alphanumeric or one of a set of possible values. A drop down list is the second 
type of input box a user can encounter. If the values of a property are from a set of previously 
defined values, a dropdown list will appear by clicking the small down arrow that appears on the 
right-hand side of the box. Select the desired value by clicking on it. The third option is a dialog 
box. Some properties require more than one value to set the property (such as fonts). With these 
properties, a button with three small dots (called an ellipse) appears on the right-hand corner of 
the property edit box. By clicking on the dots, a dialog box (or wizard) will appear and from this 
dialog box the multiple properties can be set. 

 

 

Right-Click Menu  
A popup menu will appear when the Property Panel is right-clicked on. This speed menu can be 
used to set various options of the Property Panel. 

Property Hints, the first menu item, hides or shows the Property Hints box which is located at the 
very bottom of the Property Panel. Highlight Changes, the second menu item, enables or disables 
the showing of the properties in bold for items that have been changed. Exclude Name, Size and 
Pos Changes, the third menu item, determines whether Name, Size and position changes (like 
width and height) are included in the properties that will be bolded when the default value has 
been changed. The third menu item becomes helpful when many properties have been changed, 
and there is a need to see changed properties that are not commonly changed. 

Exercise: Navigating the Property Panel  
Opening the Property Panel 
1. If the Property Panel is not visible, then go to the Tools Menu. From the Tools sub-

menu, choose Property Panel. Make sure that there is a check mark next to the 
selection. 

 

Identifying Property Panel Areas 
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2. For this example, the base component, the Page, will be used. So, to select the Page 
component, click on the page tab in the Page Designer Tab area. Notice that after 
selecting the Page, its properties are displayed in the Property Panel. 

3. Next make sure that the Property Hints box is visible at the bottom of the Property Panel, 
if it isn't already. Right-click anywhere in the Property Panel. A pop-up menu will appear. 
In this menu, check all the options available. 

4. Expand the Property Panel out so that you can see all the properties as well as the 
Property Hints box. On steps 5 to 8, read the Property Hints box to find more information 
about each property. 

 

Note: The image to the right has been modified for the next few examples. 
5. Click on the Name property. Notice that it corresponds to the name at the top of the 

Property Panel "Page1: Page component". The other half of this line is the kind of 
component that the line is referring to. The component is a Page component and thus it 
is recognized as that here. Type in any name in the Name property and see the change 
reflected in the top line. The Name property is an example of an edit box of type String. 

6. Click on the Bin property down arrow. Notice that this displays a drop-down menu. Drop-
down menus give many predetermined options from which to choose. 

7. Click on the Grid Spacing input box. This is an example of a Numeric type property. To 
see what this does, change the Grid Spacing property value and look at the Page when 
done. 

8. Click on the ellipse (…) on the Parameters property to see a dialog box appear. The 
dialog box is a way that a property with multiple values and options displays its choices. 

9. In step 3, the option Highlight Changes was checked in the speed menu (right-click on 
the Property Panel). Go to the PaperSize property and choose a different paper size. 
Notice that not only does the paper size change, but that the property is bolded. This 
bolding becomes helpful in determining when properties have been changed from their 
default or initial values. Try changing other values such as the page width and height. 

10. Also, checked in step 3, is the Exclude Name, Size, and Pos Changes option. This is a 
very helpful option. In most cases the name, size, and component position on a Page 
changes often. So, to avoid highlighting these commonly changed properties, this option 
excludes them from being bolded. Try unselecting this option and changing these 
properties. 
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Chapter 7   

Generating Output  
 

 In this Section:  
  
• Learn how to execute and preview Reports 
• Explains the options in the Printing Preferences 
• Learn about the toolbars and options in the Report Preview 
• Explains the differences in the Report Designer and the Print Preview Output 
Options dialog 
• Learn how to export reports to various formats: NDR, PRN, HTML, and PDF 
 

Overview  
After a report is created, displaying and making the report electronically mobile will become the 
next necessary step. There are several ways to get reports onto paper or into electronic formats. 
This chapter will cover the different ways to display report output and will also go through simple 
printing. 

Executing Reports  
One of the most common features used in Rave is the actual report execution. Executing a report 
allows the user to see the output of the report design. Execution is very similar to what many 
developers know as compiling and actually does involve a certain amount of internal "compiling". 

There are various ways that a report can be executed. It is done either via the Project menu, 
using the F9 function key, or clicking on the Execute Report icon on the Project toolbar. 

Using the F9 function key becomes very handy since execution becomes a very repetitive and 
common task performed during all phases of design. 

When using any of the ways to execute a report, the user is presented with various options. The 
Output Options dialog shows the different options available at the time of execution. 

In later sections of this chapter, each option will be explained in further detail. 

Preferences Dialog  
Before going through each execution option, there are some preferences that need to be covered 
and kept in mind before executing a report. Going to the Edit menu and selecting Preferences will 
display the Preferences dialog box. 

The Printing tab in the Preferences dialog box allows various settings to be changed that effect 
report execution. Some of the options that can be set here are also reflected in the Output 
Options dialog box that appears when executing. In this section, each of the parameters in the 
Printing preferences will be explained. 

 In Output Options area of Printing Preferences, the Show Setup Dialog indicates whether the 
Output Options dialog (as shown here) is displayed when executing a report. It is sometimes 
convenient to disable the Output Options dialog, especially if it is during design and testing time. 
The drawback to this is that some of the parameters that are contained in the dialog box would 
have to be set before hiding this dialog. Also, any changes desired would have to be done either 
by re-activating the dialog box or specifying the changes in the Preferences dialog. 
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The default report print destination is determined by the settings under Print Destination in the 
Printing Preferences, and is reflected in the Output Options dialog box. Changing the value in the 
Print Destination area of the Printing Preferences will directly effect the default selection in the 
Output Options dialog box. There are two options that can be chosen: Preview and Printer. 
Selecting either one, by choosing the appropriate radio button, will make that option the default 
value and when the Output Options dialog appears the default value will be selected. 

The Preview Grid Options act in much the same way as the Grid (which are the lines seen on the 
Page in the Visual Designer) does during design time. These Options allow a Grid to be displayed 
on the Print Preview screen underlying the Report. The Grid settings allow changes for the Print 
Preview Page, including Grid changes for color, style, and spacing adjustment. If the spacing is 
both 0 horizontally and vertically, no grid will be displayed in the preview. But, placing numbers in 
the horizontal and vertical spacing settings, will space the grid appropriately on the Print Preview 
Page. The Line Color will change the color of the Grid. The Line Style drop-down menu will give 
different options of line styles. 

The Preview Options, as the name indicates, only affect previewing. There are six parameters 
that can be set. When using the Preview, the window displayed by default is in normal state. Like 
any other Window, the Preview can be Minimized or Maximized. To set the window display, use 
the drop down menu in the Initial Window State setting. 

The Zoom Factor indicates the default zoom percentage when the preview is first displayed. The 
Zoom Increment specifies the Zoom percentage that will occur by each click on the Zoom 
In/Zoom Out icons. As with the Page Designer, the preview screen can have a horizontal ruler, 
vertical ruler, or both by specifying this in the Ruler Type (use the drop-down menu to make the 
selection). The measurements can be indicated in either centimeters or inches. 

The ShadowDepth is the level of shadow that is displayed on the preview screen and it is only for 
on screen appearance and aesthetics. 

The Monochrome Preview Display check box is there for backward-compatibility with some video 
cards that would give problems when displaying reports in color. This is not recommended for 
use, but is there if needed. 

Report Preview  
Although the Preview is primarily used for previewing a report, the Preview option has many more 
capabilities than what is intuitively understood from its name. 

Begin by executing a report. When the Output Options dialog appears, the Preview radio button 
can be selected. Clicking OK will continue with the Preview process. 
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The Preview screen is used to see the output of the designed report. The actual appearance on 
the screen resembles that of the printed report. The screen is based on a page-by-page output. 
There is a toolbar at the top of the Preview screen that allows navigation as well as other 
functions, which are explained in the following paragraphs. 

 

 

Most of the functions permitted in the Preview screen can either be performed using the toolbar 
or through the Preview menu options. We will go through and explain the menu options in the rest 
of this section. 

The first group of icons (separated by a vertical line on the toolbar), can be found in the File 
menu. They are used for opening, saving, printing, and exiting the Preview of a report. 

Although the Preview screen displays the current report in the designer, it can also be used to 
load a previously saved report (with an NDR extension). This can be done by clicking on Open in 
the File menu. A dialog box appears prompting for the desired report file. When the NDR file is 
opened, the report that was previously in the Preview is discarded. This does not mean that the 
report can not be regenerated. To get the previous report, simply re-execute the report and 
choose Preview. Only the report that was Previewed upon execution can be regenerated. Other 
reports can only be revisited if they were previously saved or if their projects are re-opened and 
re-executed. 

The Save As is used to save the report in the Preview. Click on Save As and the Save File dialog 
appears. Use this dialog to save the current report to various formats, including PDF and HTML 
(these two formats are covered later on this chapter). Another format that a report can be saved 
to is the NDR report type, again this is a Rave snapshot of the report. 

Although reports can be printed directly by choosing Execute and then Printer, the Preview 
screen also provides this option, since many times it is necessary to check the preview of the 
report before actually printing it. 

The remaining functions directly affect the viewing of the report on the Preview screen. The 
second section on the toolbar and the items in the Page menu are used for navigation between 
pages. The buttons used to designate the options will look familiar to database users, since they 
follow the same convention. The first button is used to move to the first page of the report. The 
second button moves to the previous page. The third button is used to move to the next page, 
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and the last button can be used to move to the end of the report. On the toolbar, there is a page 
indicator, which at all times reflects the current page and the number of total pages. This page 
indicator can also be used to go to a page directly by typing the page in the edit box. Or use the 
Go to Page in the Page menu. For example, entering 10 in the edit box will display the 10th page 
of the report (providing there are 10 or more pages available). 

Zooming is also available in Preview. The magnifying glass containing a plus sign will zoom in on 
the page, while the magnifying glass with a minus sign will zoom out. Similar to the page edit box, 
there is a zoom box that is used both for displaying the actual zoom and allowing the user to 
enter a specific percentage value. Just type in a number and the Preview will be zoomed in or out 
to that zoom percentage. 

There are also two preset zoom values for fast navigation. The first one is the Fit to Page Width 
option. By clicking on this, the report can be adjusted so that the width of the page takes up the 
entire region of the preview screen. The second preset is Fit to Page. It can be used to view the 
entire page on the screen. The side effect of this is that although the report can be viewed as a 
whole, the actual contents might be difficult to read. Normally this can be used to get a general 
overview of the report layout. 

The preview window can be exited by either clicking on the Door icon located on the far right of 
the toolbar or by clicking on the "X" button on the window (like any other window). 

Executing to the Printer  
Printing can be done, as mentioned before, via the Preview screen or directly when executing the 
Report and choosing Printer as the Report Destination. One thing to notice is that the Output 
Options dialogs are a little different when selected from the Rave Designer and from the Print 
Preview. 

The Output Options dialog that appears from the Rave Designer has more options than just 
printing, as shown in the image. 

In the Output Options Dialog there is a Setup option for Printing. The Setup button is underneath 
the Cancel button and can be used to adjust the printer settings prior to the actual printing. This 
includes options such as whether the report should be printed in landscape or portrait, the 
resolution of the printer, the color depth, paper size, etc. 

The dialog box also includes several Options such as the number of copies to be printed, whether 
the copies should be collated, or duplex printed. 

In the Output Options Dialog from the Report Preview (see image), there are some different 
options available. The Print Range has three different options. The All option means to print all 
pages in the report. The Selection option means to print a selection of pages not adjacent to each 
other, i.e. "1,3,5,7" or "1,9-5,20". The Pages option prints a range of consecutive pages, i.e. "1-
10" or "15-19". 

NDR & PRN Files  
Printing to a file can be done several ways. We will discuss two that can be done directly from the 
Output Options dialog. The Output Options dialog is obtained by executing the report (use the F9 
key or execute through the Project menu). 

The NDR, or the Rave Format, is a Rave snapshot of the report. An NDR file can be seen and 
opened from the Preview window, but it cannot be changed or edited in the Rave Designer. 

The PRN file is the Native Printer Output type file. When this option is selected, the information 
that is usually sent to the printer to print a report is instead sent to a file. This file is saved based 
on the file name the user gives. 

To create either type of file, simply select desired format and then fill the empty File edit box with 
a name for the file. 
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The NDR can also be made using the Save As option in the File menu in the Report Preview 
window. Using the Save as type drop-down menu and entering a File name will create the NDR 
file. 

There are other ways to print to a file. These are only two formats. We will cover PDF and HTML 
file in the next sections. 

HTML  
Rave has the capability to save reports as HTML files. This makes it easy to have reports readily 
available over the Internet or through a company intranet. HTML files can be created in the Visual 
Designer and in the Report Preview window. 

To save a report as HTML from the Visual Designer, first get to the Output Options Dialog. Do 
this by using the Execute Report from the Project menu, or by using the F9 key. 

In the Output Options dialog box, choose the File option from the Report Destination area. Using 
the Format drop down box to get to the HTML option will set the format to HTML. Clicking on the 
disk, will allow the user to set the path of where to save the file to and to name the HTML file. 

Once a report is saved and properly formatted it may be helpful to first Preview the report. 
Preview the report by executing the report and choosing Preview from the Output Options dialog. 
After looking the report over in the Report Preview, choose the Save As option in the File menu. 
This will bring up the Save File dialog, where a report can be saved into HTML. 

To save the HTML format, in the Save as type drop-down menu, select HTML files. Then type in 
the name of the new HTML file in the File name edit box. When done, click Save. 

Each page of the report will be saved as an individual HTML file. For example, a three-page 
report would produce three pages of HTML. On each page, navigations links to the previous and 
next pages are provided. Once saved, the HTML files can be viewed with any Internet browser. 

PDF  
A truly useful report is one that is portable over many different platforms. The PDF feature of 
Rave makes this possible with the help of a free viewer. A report can be saved into PDF format, 
and through the use of the Free Adobe Acrobat Reader, any person can open, view, and print the 
report. 

This option is available through the Execute Report (also F9) option in the Visual Designer File 
menu or through Save As in the Report Preview File menu. Using the Report Preview allows the 
user to see the layout of the report before saving it into PDF format. 

After selecting Execute the Output Options dialog will appear from which the format can be 
chosen. Also, the file name of the PDF can be set. 

In the Print Preview, using Save As will bring up the Save File dialog and from there you can save 
the report as a PDF type, as well as choose the file name. 

To save a PDF, in the Save as type drop-down menu, select Adobe PDF. Then, type in the name 
of the new PDF in the File name edit box. When done, click Save. 

RTF  
Rave also has the capability to save reports as a RTF (Rich Text Format) file. This file format can 
be loaded into many word processors for a wide variety of reasons. For example, your report(s) 
could be included in a company document as an attachment. Or a report could be loaded into a 
word processor and then selected lines could be edited (highlighted, bold) to emphasis a point to 
a particular audience. 

This option is available through the Execute Report (also F9) option in the Visual Designer File 
menu or through Save As in the Report Preview File menu. Using the Report Preview allows the 
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user to see the layout of the report before saving it into RTF format. 

After selecting Execute the Output Options dialog will appear from which the output format can be 
chosen. Also, the file name of the output file can be set. 

In the Print Preview, using "Save As" will bring up the "Save File" dialog and from there you can 
save the report as a RTF type, as well as choose the file name. 

To save a RTF, in the "Save As" type drop-down menu, select RTF. Then, type in the name of 
the new RTF in the File name edit box. When done, click Save. 

Exercise: Changing Printing Preferences  
Change Print Destination 
1. Before beginning this exercise, create a new Project and place a few visual and text 

components on the Page. 
2. First, go to the Printing Preferences tab by either using the Edit Preferences icon on the 

Designer Toolbar, or by selecting Preferences in the Edit menu. 
3. Click on Printing in the Preferences option area (left of the screen). 
4. Look at the Print Destination area and select Preview. 
5. Now close the Preferences window by selecting the OK button. 
6. Execute the report by pressing the F9 key, or by selecting Execute from the File menu. 
7. When the Output Options dialog appears, notice that the Preview option is the default 

value selected. Click Cancel when done. 
8. Now, open the Printing Preferences again, and select Printer as the Print Destination. 

Click OK when done. 
9. Execute the report again, and in the Output Options dialog, notice that the Printer is now 

the default value selected. 

 

Change Setup Options 
1. Before beginning this exercise, create a new Project and place a few visual and text 

components on the Page. 
2. First, go to the Printing Preferences by either using the Edit Preferences icon on the 

Designer Toolbar, or by selecting Preferences in the Edit menu. 
3. Next, make sure that Preview is selected in Print Destination. 
4. Uncheck the Show Output Options Dialog in the Output Options area. 
5. Select OK to close the Preferences dialog. 
6. Execute the report by pressing the F9 key, or by selecting Execute from the File menu. 

Notice that the Output Options Dialog did not appear; instead the execution went directly 
to the Preview. If Printer had been selected in the Print Destination, the report would 
have been sent to the printer. 

7. To get the Output Options dialog back, go to the Printing Preferences and re-check the 
Show Output Options Dialog in the Output Options area. 

 

Grid Lines and Options in Preview 
1. Before beginning this exercise, create a new Project and place a few visual and text 

components on the Page. 
2. First, go to Printing Preferences by either using the Edit Preferences icon on the 

Designer Toolbar, or by selecting Preferences in the Edit menu. 
3. Next, make sure that Preview is selected in Print Destination and uncheck the Show 

Output Options Dialog in the Output Options area. We will be exploring the Preview for 
this exercise, so using the Print Destination and Show Output Options Dialog to 
execute quickly to Preview will be very helpful. 
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execute quickly to Preview will be very helpful. 
4. When in the Printing Preferences dialog, make sure the initial values of the Preview Grid 

Options and the Preview Options are exactly as seen in the image. 
5. Click OK, when done. 
6. Execute the report and just view the Preview of the window. 
7. Now close the Preview window, and Open up the Printing Preferences. 
8. In the Preview Grid Options, change the Horizontal Spacing and Vertical Spacing to 1. 

Then change the line color by clicking on the color wheel. 
9. Click OK when done. 
10. Execute the report and notice the lines on the report in the Preview. These lines will not 

appear on a print out, but are there if needed to help check layout and formatting. 
11. Now, close the Preview and go to the Printing Preferences again. Change the Line Style 

in the Preview Grid Options area to Dash. Also, change the Initial Window State  to 
Minimized. 

12. Then, in the Preview Options, change the Ruler Type to BothIn. This will display both 
the horizontal and vertical ruler in inches in the Preview. Also, change the Shadow 
Depth to 10. 

13. Click OK when done. 
14. Execute the report. 
15. First of all noticed that the Preview is minimized. This was set by the Initial Window 

State. To expand the window to see the Preview, click on the first or second button. 
16. Once the window is restored or maximized. There are several things to notice. First see 

the dashed gridlines on the Page. These can be useful to check object alignment on the 
Page. Also, notice the vertical and horizontal ruler. At the very far right edge of the Page, 
notice the deep shadow behind the Page. 

17. When done, go back into the Printing Preferences dialog. Put all settings back to their 
original values. The image shown displays our values. These values will be used for the 
remaining exercises in this chapter. 

 

Exercise: Preview and Creating Portable Files  
1. Before beginning, create a New Project. And on four pages, place text and objects.  
2. Link the four pages together. Selecting the Page and the Property Panel was covered in 

the previous chapter. Select the first page and in the Property Panel use the drop-down 
menu in GotoPage to select Page2. Do this for every page. Select page 2, and make 
GotoPage equal to Page3. Select page 3, and make GotoPage equal to Page4. 

3. Next, go to the Preview window by executing the report. Select Preview from the Output 
Options dialog. 

4. At the top of the Preview window on the toolbar, there should be an edit box that has the 
number 1. That area should read Page 1 of 4. 

 

Navigating through Preview 
5. Since there is more than one page, use the navigation buttons on the toolbar or in the 

Page  menu. Use the Go to Page # to jump to any page in the report. 
6. Next, use the zoom tools to get a closer and an overall look of the report pages. This 

also will allow you to become more familiar with moving around in the Preview. 

 

Creating an NDR File through the Preview 
7. To create an NDR (a Rave Snapshot File) from the Preview Window, go to the Save As 

option in the File menu. 
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8. When the Save File dialog appears, use the Save as type drop-down menu to select 
NDR files. And put in the name of the NDR file in the File name edit box, in this example 
we used Text.ndr. Click Save  when done. 

9. Even though the file is already in the Preview, let's try opening the Test.ndr file. 
10. Choose Open in the File menu. 
11. The Open File dialog will appear. Look for the Test.ndr file in the directory you placed it. 

Click Open when done. 
12. The Preview will most likely look the same, as we did not change the report. But, look at 

the top of the Preview window to where the name of the file is listed. So, as you peruse 
through different NDR files, the name will always be listed at the top of the Preview. 
Nothing in an NDR file can be changed; it is simply a way to view the report. 

 

Creating a PDF file through the Preview 
13. Since we are no longer using the executed file, close the Preview window. Execute the 

file and select Preview again. 
14. Now, select Open from the File menu. 
15. In the Save File dialog, select Adobe PDF from the Save as type drop-down menu. 

Then, type in a name in the File name edit box, this example uses test.pdf. 
16. Click Save  when done. 
17. At this point you can go out to where your file was saved and open the PDF file. If you do 

not have the PDF reader, go to www.adobe.com and download the free reader. 

 

Creating HTML Files 
18. In the Preview window, select Open from the File menu. 
19. In the Save File dialog, choose HTML File in the drop-down menu for Save as type. 

Then type in a name in the File name edit box. 
20. Click Save  when done. 
21. When done you can go to the HTML file that was saved. We saved our html files in My 

Documents. You will notice that there are four pages of the test.html, with consecutive 
numbers after the test title. Each page in the report will have an associated HTML page. 

22. Below is the first page of our test.html. This is test1.html, as it is the first page. Note that 
at the bottom there are navigation links to the get to the next pages. 
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Exercise: Printing a Report through the Preview  
1. In the Preview window, select Print from the File menu. 
2. This will bring up the Output Options dialog. Use any of the print ranges to get any of the 

pages of the report that you want. 
3. When done, close the preview window. 
4. Then execute the report, and select Printer. This too will send your report to the printer. 

 

Exercise: Printing to a File (NDR & PRN)  
1. Execute a report and select File. 
2. In the Format drop-down box, there will be two options. Rave Format (.NDR) and 

Native Printer Output (.PRN). 
3. Make the desired choice. 
4. In the edit box next to File, type in the name of the file. 
5. Click OK when done 

 



RAVE Reference Manual 

Page 48 


